What’s Vulnerable › Vulnerabilities
CVE-2021-21995
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-13 · updated 2026-06-17
- Weakness: CWE-125
Description
OpenSLP as used in ESXi has a denial-of-service vulnerability due a heap out-of-bounds read issue. A malicious actor with network access to port 427 on ESXi may be able to trigger a heap out-of-bounds read in OpenSLP service resulting in a denial-of-service condition.
Affected products
- VMware Cloud Foundation: from 3.0 before 3.10.2; from 4.0 before 4.3 — fixed in 3.10.2, 4.3
- VMware ESXi: 6.5-650-201701001, 6.5-650-201703001, 6.5-650-201703002, 6.5-650-201704001, 6.5-650-201707101, 6.5-650-201707102 (+227); 6.5, 6.7, 7.0
- VMware ESXi and VMware Cloud Foundation: VMware ESXi(7.0 before ESXi70U2-17630552, 6.7 before ESXi670-202103101-SG, 6.5 before ESXi650-202107401-SG) and VMware Cloud Foundation (4.x, 3.x before 3.10.2)
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 3.10.2, 4.3. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2021-0014.html
- https://www.vmware.com/security/advisories/VMSA-2021-0014.html
Get alerted when CVE-2021-21995 or the next vulnerability affects your stack