What’s Vulnerable › Vulnerabilities
CVE-2021-22001
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-22 · updated 2026-06-17
- Weakness: CWE-200
Description
In UAA versions prior to 75.3.0, sensitive information like relaying secret of the provider was revealed in response when deletion request of an identity provider( IdP) of type “oauth 1.0” was sent to UAA server.
Affected products
- Cloud Foundry cf-deployment: before 16.18.0 — fixed in 16.18.0
- Cloudfoundry User Account And Authentication: before 75.3.0 — fixed in 75.3.0
How to fix
Upgrade to a fixed version: Cloud Foundry cf-deployment 16.18.0; Cloudfoundry User Account And Authentication 75.3.0. Check the vendor advisory for mitigations.
References
- https://www.cloudfoundry.org/blog/cve-2021-22001-sensitive-info-leakage-in-uaa-during-identity-provider-deletion/
- https://www.cloudfoundry.org/blog/cve-2021-22001-sensitive-info-leakage-in-uaa-during-identity-provider-deletion/
Get alerted when CVE-2021-22001 or the next vulnerability affects your stack