What’s Vulnerable › Vulnerabilities
CVE-2021-22007
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-23 · updated 2026-06-17
Description
The vCenter Server contains a local information disclosure vulnerability in the Analytics service. An authenticated user with non-administrative privilege may exploit this issue to gain access to sensitive information.
Affected products
- VMware Cloud Foundation: from 3.0 before 5.0 — fixed in 5.0
- VMware vCenter Server: 6.7, 7.0
- VMware vCenter Server, VMware Cloud Foundation: VMware vCenter Server(7.x before 7.0 U2c and 6.7 before 6.7 U3o) and VMware Cloud Foundation (4.x before 4.3 and 3.x before 3.10.2.2)
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 5.0. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2021-0020.html
- https://www.vmware.com/security/advisories/VMSA-2021-0020.html
Get alerted when CVE-2021-22007 or the next vulnerability affects your stack