What’s Vulnerable › Vulnerabilities
CVE-2021-22015
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-23 · updated 2026-06-17
- Weakness: CWE-552
Description
The vCenter Server contains multiple local privilege escalation vulnerabilities due to improper permissions of files and directories. An authenticated local user with non-administrative privilege may exploit these issues to elevate their privileges to root on vCenter Server Appliance.
Affected products
- VMware Cloud Foundation: from 3.0 before 5.0 — fixed in 5.0
- VMware vCenter Server: 6.5, 6.7, 7.0
- VMware vCenter Server, VMware Cloud Foundation: VMware vCenter Server(7.x before 7.0 U2c, 6.7 before 6.7 U3o and 6.5 before 6.5 U3q) and VMware Cloud Foundation (4.x before 4.3 and 3.x before 3.10.2.2)
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 5.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/170116/VMware-vCenter-vScalation-Privilege-Escalation.html
- https://www.vmware.com/security/advisories/VMSA-2021-0020.html
- http://packetstormsecurity.com/files/170116/VMware-vCenter-vScalation-Privilege-Escalation.html
- https://www.vmware.com/security/advisories/VMSA-2021-0020.html
Get alerted when CVE-2021-22015 or the next vulnerability affects your stack