What’s Vulnerable › Vulnerabilities
CVE-2021-22016
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The vCenter Server contains a reflected cross-site scripting vulnerability due to a lack of input sanitization. An attacker may exploit this issue to execute malicious scripts by tricking a victim into clicking a malicious link.
Affected products
- VMware Cloud Foundation: from 3.0 before 5.0 — fixed in 5.0
- VMware vCenter Server: 6.7
- VMware vCenter Server, VMware Cloud Foundation: VMware vCenter Server 6.7 before 6.7 U3o and VMware Cloud Foundation 3.x before 3.10.2.2
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 5.0. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2021-0020.html
- https://www.vmware.com/security/advisories/VMSA-2021-0020.html
Get alerted when CVE-2021-22016 or the next vulnerability affects your stack