What’s Vulnerable › Vulnerabilities
CVE-2021-22023
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-30 · updated 2026-06-17
- Weakness: CWE-639
Description
The vRealize Operations Manager API (8.x prior to 8.5) has insecure object reference vulnerability. A malicious actor with administrative access to vRealize Operations Manager API may be able to modify other users information leading to an account takeover.
Affected products
- VMware Cloud Foundation: from 3.0 through 3.10.2.1; from 4.0 through 4.2.1
- VMware Vrealize Operations Manager: from 8.0.0 before 8.5.0; 7.5.0 — fixed in 8.5.0
- VMware Vrealize Suite Lifecycle Manager: from 8.0 through 8.2
- VMware vRealize Operations: from VMware vRealize Operations (8.x prior through 8.5)
How to fix
Upgrade to a fixed version: VMware Vrealize Operations Manager 8.5.0. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2021-0018.html
- https://www.vmware.com/security/advisories/VMSA-2021-0018.html
Get alerted when CVE-2021-22023 or the next vulnerability affects your stack