What’s Vulnerable › Vulnerabilities
CVE-2021-22028
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-19 · updated 2026-06-17
- Weakness: CWE-22
Description
In versions of Greenplum database prior to 5.28.6 and 6.14.0, greenplum database contains a file path traversal vulnerability leading to information disclosure from the file system. A malicious user can read/write information from the file system using this vulnerability.
Affected products
- GPDB (Greenplum database): before 5.28.6; from 6.0.0 before 6.14.0 — fixed in 5.28.6, 6.14.0
How to fix
Upgrade to a fixed version: GPDB (Greenplum database) 5.28.6, 6.14.0. Check the vendor advisory for mitigations.
References
- https://github.com/greenplum-db/gpdb/security/advisories/GHSA-hqh5-m87w-57w2
- https://github.com/greenplum-db/gpdb/security/advisories/GHSA-hqh5-m87w-57w2
Get alerted when CVE-2021-22028 or the next vulnerability affects your stack