What’s Vulnerable › Vulnerabilities
CVE-2021-22029
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-31 · updated 2026-06-17
- Weakness: CWE-770
Description
VMware Workspace ONE UEM REST API contains a denial of service vulnerability. A malicious actor with access to /API/system/admins/session could cause an API denial of service due to improper rate limiting.
Affected products
- VMware Workspace ONE UEM console: from 20.1.0.0 before 20.1.0.33; from 20.5.0.0 before 20.5.0.51; from 20.8.0.0 before 20.8.0.32; from 20.11.0.0 before 20.11.0.30; from 21.2.0.0 before 21.2.0.14; from 21.5.0.0 before 21.5.0.2 — fixed in 20.1.0.33, 20.11.0.30, 20.5.0.51, 20.8.0.32, 21.2.0.14, 21.5.0.2
- Vmware Workspace One UEM console: Workspace ONE UEM console 2105, 2102, 2011, 2008, 2005 & 2001
How to fix
Upgrade to a fixed version: VMware Workspace ONE UEM console 20.1.0.33, 20.11.0.30, 20.5.0.51, 20.8.0.32. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2021-0017.html
- https://www.vmware.com/security/advisories/VMSA-2021-0017.html
Get alerted when CVE-2021-22029 or the next vulnerability affects your stack