What’s Vulnerable › Vulnerabilities
CVE-2021-22030
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-19 · updated 2026-06-17
- Weakness: CWE-532
Description
In versions of Greenplum database prior to 5.28.14 and 6.17.0, certain statements execution led to the storage of sensitive(credential) information in the logs of the database. A malicious user with access to logs can read sensitive(credentials) information about users
Affected products
- GPDB (Greenplum database): before 5.28.14; from 6.0.0 before 6.17.0 — fixed in 5.28.14, 6.17.0
How to fix
Upgrade to a fixed version: GPDB (Greenplum database) 5.28.14, 6.17.0. Check the vendor advisory for mitigations.
References
- https://github.com/greenplum-db/gpdb/security/advisories/GHSA-c7w8-gx27-h4mr
- https://github.com/greenplum-db/gpdb/security/advisories/GHSA-c7w8-gx27-h4mr
Get alerted when CVE-2021-22030 or the next vulnerability affects your stack