What’s Vulnerable › Vulnerabilities
CVE-2021-22042
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-16 · updated 2026-06-17
- Weakness: CWE-863
Description
VMware ESXi contains an unauthorized access vulnerability due to VMX having access to settingsd authorization tickets. A malicious actor with privileges within the VMX process only, may be able to access settingsd service running as a high privileged user.
Affected products
- VMware Cloud Foundation: from 4.0 before 4.4 — fixed in 4.4
- VMware ESXi: 7.0-update_1, 7.0-update_2, 7.0-update_3
- VMware ESXi and VMware Cloud Foundation: VMware ESXi(7.0 U3 before ESXi70U3c-19193900, 7.0 U2 before ESXi70U2e-19290878 and 7.0 U1 before ESXi70U1e-19324898) and VMware Cloud Foundation 4.x before 4.4
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 4.4. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2022-0004.html
- https://www.vmware.com/security/advisories/VMSA-2022-0004.html
Get alerted when CVE-2021-22042 or the next vulnerability affects your stack