What’s Vulnerable › Vulnerabilities
CVE-2021-22045
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-04 · updated 2026-06-17
- Weakness: CWE-787
Description
VMware ESXi (7.0, 6.7 before ESXi670-202111101-SG and 6.5 before ESXi650-202110101-SG), VMware Workstation (16.2.0) and VMware Fusion (12.2.0) contains a heap-overflow vulnerability in CD-ROM device emulation. A malicious actor with access to a virtual machine with CD-ROM device emulation may be able to exploit this vulnerability in conjunction with other issues to execute code on the hypervisor from a virtual machine.
Affected products
- VMware Cloud Foundation: from 3.0 through 3.10.2.2; from 4.0 through 4.3.1
- VMware ESXi: 6.5-650-201701001, 6.5-650-201703001, 6.5-650-201703002, 6.5-650-201704001, 6.5-650-201707101, 6.5-650-201707102 (+204); 6.5, 6.7, 7.0
- VMware Fusion: from 12.0.0 before 12.2.0 — fixed in 12.2.0
- VMware Workstation: from 16.0.0 before 16.2.0 — fixed in 16.2.0
- VMware ESXi, VMware Workstation and VMware Fusion: VMware ESXi (7.0, 6.7 before ESXi670-202111101-SG and 6.5 before ESXi650-202110101-SG), VMware Workstation (16.2.0) and VMware Fusion (12.2.0)
How to fix
Upgrade to a fixed version: VMware Fusion 12.2.0; VMware Workstation 16.2.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/165440/VMware-Security-Advisory-2022-0001.html
- https://www.vmware.com/security/advisories/VMSA-2022-0001.html
- https://www.zerodayinitiative.com/advisories/ZDI-22-003/
- http://packetstormsecurity.com/files/165440/VMware-Security-Advisory-2022-0001.html
- https://www.vmware.com/security/advisories/VMSA-2022-0001.html
- https://www.zerodayinitiative.com/advisories/ZDI-22-003/
Get alerted when CVE-2021-22045 or the next vulnerability affects your stack