What’s Vulnerable › Vulnerabilities
CVE-2021-22050
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-16 · updated 2026-06-17
- Weakness: CWE-770
Description
ESXi contains a slow HTTP POST denial-of-service vulnerability in rhttpproxy. A malicious actor with network access to ESXi may exploit this issue to create a denial-of-service condition by overwhelming rhttpproxy service with multiple requests.
Affected products
- VMware Cloud Foundation: from 3.0 before 3.11; from 4.0 before 4.4 — fixed in 3.11, 4.4
- VMware ESXi: 6.7-670-201806001, 6.7-670-201807001, 6.7-670-201808001, 6.7-670-201810001, 6.7-670-201810101, 6.7-670-201810102 (+155); 6.5, 6.7
- VMware ESXi and VMware Cloud Foundation: VMware ESXi(7.0 U3 before ESXi70U3c-19193900, ESXi 6.7 ESXi670-202111101-SG and ESXi 6.5 before ESXi650-202110101-SG) and VMware Cloud Foundation (4.x before 4.4 and 3.x before 3.11)
How to fix
Upgrade to a fixed version: VMware Cloud Foundation 3.11, 4.4. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2022-0004.html
- https://www.vmware.com/security/advisories/VMSA-2022-0004.html
Get alerted when CVE-2021-22050 or the next vulnerability affects your stack