What’s Vulnerable › Vulnerabilities

CVE-2021-22051

Description

Applications using Spring Cloud Gateway are vulnerable to specifically crafted requests that could make an extra request on downstream services. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.5+, 2.2.x users should upgrade to 2.2.10.RELEASE or newer.

Affected products

How to fix

Upgrade to a fixed version: Spring Cloud Gateway 2.2.10, 3.0.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-22051 or the next vulnerability affects your stack