What’s Vulnerable › Vulnerabilities
CVE-2021-22054: Omnissa Workspace ONE Server-Side Request Forgery
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-03-09
- EPSS: 99.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-17 · updated 2026-10-01
- Weakness: CWE-918
Description
VMware Workspace ONE UEM console 20.0.8 prior to 20.0.8.37, 20.11.0 prior to 20.11.0.40, 21.2.0 prior to 21.2.0.27, and 21.5.0 prior to 21.5.0.37 contain an SSRF vulnerability. This issue may allow a malicious actor with network access to UEM to send their requests without authentication and to gain access to sensitive information.
Affected products
- VMware Workspace ONE UEM console: from 20.0.8.0 before 20.0.8.36; from 20.11.0.0 before 20.11.0.40; from 21.2.0.0 before 21.2.0.27; from 21.5.0.0 before 21.5.0.37 — fixed in 20.0.8.36, 20.11.0.40, 21.2.0.27, 21.5.0.37
- Vmware Workspace One UEM console: from VMware Workspace ONE UEM console 20.0.8 prior through 20.0.8.37, 20.11.0 prior to 20.11.0.40, 21.2.0 prior to 21.2.0.27, and 21.5.0 prior to 21.5.0.37.
How to fix
Upgrade to a fixed version: VMware Workspace ONE UEM console 20.0.8.36, 20.11.0.40, 21.2.0.27, 21.5.0.37. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2021-0029.html
- https://www.vmware.com/security/advisories/VMSA-2021-0029.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-22054
- https://www.greynoise.io/blog/new-ssrf-exploitation-surge
Get alerted when CVE-2021-22054 or the next vulnerability affects your stack