What’s Vulnerable › Vulnerabilities
CVE-2021-22100
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-25 · updated 2026-06-17
- Weakness: CWE-400
Description
In cloud foundry CAPI versions prior to 1.122, a denial-of-service attack in which a developer can push a service broker that (accidentally or maliciously) causes CC instances to timeout and fail is possible. An attacker can leverage this vulnerability to cause an inability for anyone to push or manage apps.
Affected products
- Cloud Foundry CAPI: before 1.122.0 — fixed in 1.122.0
- Cloud Foundry cf-deployment: before 17.1.0 — fixed in 17.1.0
How to fix
Upgrade to a fixed version: Cloud Foundry CAPI 1.122.0; Cloud Foundry cf-deployment 17.1.0. Check the vendor advisory for mitigations.
References
- https://www.cloudfoundry.org/blog/cve-2021-22100-cloud-controller-is-vulnerable-to-denial-of-service-due-to-misbehaving-service-brokers/
- https://www.cloudfoundry.org/blog/cve-2021-22100-cloud-controller-is-vulnerable-to-denial-of-service-due-to-misbehaving-service-brokers/
Get alerted when CVE-2021-22100 or the next vulnerability affects your stack