What’s Vulnerable › Vulnerabilities
CVE-2021-22101
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-27 · updated 2026-06-17
- Weakness: CWE-400
Description
Cloud Controller versions prior to 1.118.0 are vulnerable to unauthenticated denial of Service(DoS) vulnerability allowing unauthenticated attackers to cause denial of service by using REST HTTP requests with label_selectors on multiple V3 endpoints by generating an enormous SQL query.
Affected products
- Cloud Foundry CAPI: before 1.118.0 — fixed in 1.118.0
- Cloud Foundry cf-deployment: before 16.24.0 — fixed in 16.24.0
How to fix
Upgrade to a fixed version: Cloud Foundry CAPI 1.118.0; Cloud Foundry cf-deployment 16.24.0. Check the vendor advisory for mitigations.
References
- https://www.cloudfoundry.org/blog/cve-2021-22101-cloud-controller-is-vulnerable-to-unauthenticated-denial-of-service/
- https://www.cloudfoundry.org/blog/cve-2021-22101-cloud-controller-is-vulnerable-to-unauthenticated-denial-of-service/
Get alerted when CVE-2021-22101 or the next vulnerability affects your stack