What’s Vulnerable › Vulnerabilities
CVE-2021-22115
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-08 · updated 2026-06-17
- Weakness: CWE-522
Description
Cloud Controller API versions prior to 1.106.0 logs service broker credentials if the default value of db logging config field is changed. CAPI database logs service broker password in plain text whenever a job to clean up orphaned items is run by Cloud Controller.
Affected products
- Cloud Foundry CAPI: before 1.106.0 — fixed in 1.106.0
- Cloud Foundry cf-deployment: before 16.2.0 — fixed in 16.2.0
How to fix
Upgrade to a fixed version: Cloud Foundry CAPI 1.106.0; Cloud Foundry cf-deployment 16.2.0. Check the vendor advisory for mitigations.
References
- https://www.cloudfoundry.org/blog/cve-2021-22115-capi-logs-service-broker-credentials/
- https://www.cloudfoundry.org/blog/cve-2021-22115-capi-logs-service-broker-credentials/
Get alerted when CVE-2021-22115 or the next vulnerability affects your stack