What’s Vulnerable › Vulnerabilities
CVE-2021-22116
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-08 · updated 2026-06-17
- Weakness: CWE-400
Description
RabbitMQ all versions prior to 3.8.16 are prone to a denial of service vulnerability due to improper input validation in AMQP 1.0 client connection endpoint. A malicious user can exploit the vulnerability by sending malicious AMQP messages to the target RabbitMQ instance having the AMQP 1.0 plugin enabled.
Affected products
- Debian Linux: 9.0
- VMware Tanzu RabbitMQ: before 3.8.16 — fixed in 3.8.16
- RabbitMQ: RabbitMQ prior to version 3.8.16
How to fix
Upgrade to a fixed version: VMware Tanzu RabbitMQ 3.8.16. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2021/07/msg00011.html
- https://tanzu.vmware.com/security/cve-2021-22116
- https://lists.debian.org/debian-lts-announce/2021/07/msg00011.html
- https://tanzu.vmware.com/security/cve-2021-22116
Get alerted when CVE-2021-22116 or the next vulnerability affects your stack