What’s Vulnerable › Vulnerabilities
CVE-2021-22117
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-18 · updated 2026-06-17
- Weakness: CWE-94
Description
RabbitMQ installers on Windows prior to version 3.8.16 do not harden plugin directory permissions, potentially allowing attackers with sufficient local filesystem permissions to add arbitrary plugins.
Affected products
- rabbitmq-server: from 3.8.0 before 3.8.16 — fixed in 3.8.16
How to fix
Upgrade to a fixed version: rabbitmq-server 3.8.16. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-22117 or the next vulnerability affects your stack