What’s Vulnerable › Vulnerabilities

CVE-2021-22118

Description

In Spring Framework, versions 5.2.x prior to 5.2.15 and versions 5.3.x prior to 5.3.7, a WebFlux application is vulnerable to a privilege escalation: by (re)creating the temporary storage directory, a locally authenticated malicious user can read or modify files that have been uploaded to the WebFlux application, or overwrite arbitrary files with multipart request data.

Affected products

How to fix

Upgrade to a fixed version: Spring Framework 5.2.15, 5.3.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-22118 or the next vulnerability affects your stack