What’s Vulnerable › Vulnerabilities
CVE-2021-22123
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 84.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-01 · updated 2026-06-17
- Weakness: CWE-78
Description
An OS command injection vulnerability in FortiWeb's management interface 6.3.7 and below, 6.2.3 and below, 6.1.x, 6.0.x, 5.9.x may allow a remote authenticated attacker to execute arbitrary commands on the system via the SAML server configuration page.
Affected products
- Fortinet FortiWeb: from 5.9.0 before 6.2.4; from 6.3.0 before 6.3.8 — fixed in 6.2.4, 6.3.8
How to fix
Upgrade to a fixed version: Fortinet FortiWeb 6.2.4, 6.3.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-22123 or the next vulnerability affects your stack