What’s Vulnerable › Vulnerabilities
CVE-2021-22124
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-04 · updated 2026-06-17
- Weakness: CWE-400
Description
An uncontrolled resource consumption (denial of service) vulnerability in the login modules of FortiSandbox 3.2.0 through 3.2.2, 3.1.0 through 3.1.4, and 3.0.0 through 3.0.6; and FortiAuthenticator before 6.0.6 may allow an unauthenticated attacker to bring the device into an unresponsive state via specifically-crafted long request parameters.
Affected products
- Fortinet FortiAuthenticator: from 4.0.0 through 4.3.4; from 5.0.0 through 5.5.0; from 6.0.0 before 6.0.6 — fixed in 6.0.6
- Fortinet FortiSandbox: from 3.0.0 before 3.0.7; from 3.1.0 before 3.1.5; from 3.2.0 before 3.2.2 — fixed in 3.0.7, 3.1.5, 3.2.2
How to fix
Upgrade to a fixed version: Fortinet FortiAuthenticator 6.0.6; Fortinet FortiSandbox 3.0.7, 3.1.5, 3.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-22124 or the next vulnerability affects your stack