What’s Vulnerable › Vulnerabilities
CVE-2021-22129
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-09 · updated 2026-06-17
- Weakness: CWE-120
Description
Multiple instances of incorrect calculation of buffer size in the Webmail and Administrative interface of FortiMail before 6.4.5 may allow an authenticated attacker with regular webmail access to trigger a buffer overflow and to possibly execute unauthorized code or commands via specifically crafted HTTP requests.
Affected products
- Fortinet FortiMail: through 5.4.12; from 5.6.1 before 6.0.11; from 6.2.0 before 6.2.7; from 6.4.0 before 6.4.5 — fixed in 6.0.11, 6.2.7, 6.4.5
How to fix
Upgrade to a fixed version: Fortinet FortiMail 6.0.11, 6.2.7, 6.4.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-22129 or the next vulnerability affects your stack