What’s Vulnerable › Vulnerabilities
CVE-2021-22130
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-03 · updated 2026-06-17
- Weakness: CWE-787
Description
A stack-based buffer overflow vulnerability in FortiProxy physical appliance CLI 2.0.0 to 2.0.1, 1.2.0 to 1.2.9, 1.1.0 to 1.1.6, 1.0.0 to 1.0.7 may allow an authenticated, remote attacker to perform a Denial of Service attack by running the `diagnose sys cpuset` with a large cpuset mask value. Fortinet is not aware of any successful exploitation of this vulnerability that would lead to code execution.
Affected products
- Fortinet FortiProxy: from 1.0.0 through 1.0.7; from 1.1.0 through 1.1.6; from 1.2.0 before 1.2.10; from 2.0.0 before 2.0.2 — fixed in 1.2.10, 2.0.2
How to fix
Upgrade to a fixed version: Fortinet FortiProxy 1.2.10, 2.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-22130 or the next vulnerability affects your stack