What’s Vulnerable › Vulnerabilities
CVE-2021-22137
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-13 · updated 2026-06-17
- Weakness: CWE-200
Description
In Elasticsearch versions before 7.11.2 and 6.8.15 a document disclosure flaw was found when Document or Field Level Security is used. Search queries do not properly preserve security permissions when executing certain cross-cluster search queries. This could result in the search disclosing the existence of documents the attacker should not be able to view. This could result in an attacker gaining additional insight into potentially sensitive indices.
Affected products
- Elasticsearch: before 6.8.15; from 7.11.0 before 7.11.2 — fixed in 6.8.15, 7.11.2
How to fix
Upgrade to a fixed version: Elasticsearch 6.8.15, 7.11.2. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elastic-stack-7-12-0-and-6-8-15-security-update/268125
- https://security.netapp.com/advisory/ntap-20210625-0003/
- https://discuss.elastic.co/t/elastic-stack-7-12-0-and-6-8-15-security-update/268125
- https://security.netapp.com/advisory/ntap-20210625-0003/
Get alerted when CVE-2021-22137 or the next vulnerability affects your stack