What’s Vulnerable › Vulnerabilities
CVE-2021-22138
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-13 · updated 2026-06-17
- Weakness: CWE-295
Description
In Logstash versions after 6.4.0 and before 6.8.15 and 7.12.0 a TLS certificate validation flaw was found in the monitoring feature. When specifying a trusted server CA certificate Logstash would not properly verify the certificate returned by the monitoring server. This could result in a man in the middle style attack against the Logstash monitoring data.
Affected products
- Elastic Logstash: from 6.4.0 before 6.8.15; from 7.0.0 before 7.12.0 — fixed in 6.8.15, 7.12.0
How to fix
Upgrade to a fixed version: Elastic Logstash 6.8.15, 7.12.0. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elastic-stack-7-12-0-and-6-8-15-security-update/268125
- https://security.netapp.com/advisory/ntap-20210629-0001/
- https://discuss.elastic.co/t/elastic-stack-7-12-0-and-6-8-15-security-update/268125
- https://security.netapp.com/advisory/ntap-20210629-0001/
Get alerted when CVE-2021-22138 or the next vulnerability affects your stack