What’s Vulnerable › Vulnerabilities
CVE-2021-22144
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-26 · updated 2026-06-17
- Weakness: CWE-674
Description
In Elasticsearch versions before 7.13.3 and 6.8.17 an uncontrolled recursion vulnerability that could lead to a denial of service attack was identified in the Elasticsearch Grok parser. A user with the ability to submit arbitrary queries to Elasticsearch could create a malicious Grok query that will crash the Elasticsearch node.
Affected products
- Elasticsearch: before 6.8.17; from 7.0.0 before 7.13.3 — fixed in 6.8.17, 7.13.3
- Oracle Communications Cloud Native Core Automated Test Suite: 1.8.0
How to fix
Upgrade to a fixed version: Elasticsearch 6.8.17, 7.13.3. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elasticsearch-7-13-3-and-6-8-17-security-update/278100
- https://security.netapp.com/advisory/ntap-20210827-0006/
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://discuss.elastic.co/t/elasticsearch-7-13-3-and-6-8-17-security-update/278100
- https://security.netapp.com/advisory/ntap-20210827-0006/
- https://www.oracle.com/security-alerts/cpuapr2022.html
Get alerted when CVE-2021-22144 or the next vulnerability affects your stack