What’s Vulnerable › Vulnerabilities
CVE-2021-22147
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-15 · updated 2026-06-17
- Weakness: CWE-732
Description
Elasticsearch before 7.14.0 did not apply document and field level security to searchable snapshots. This could lead to an authenticated user gaining access to information that they are unauthorized to view.
Affected products
- Elasticsearch: from 7.11.0 before 7.14.0 — fixed in 7.14.0
How to fix
Upgrade to a fixed version: Elasticsearch 7.14.0. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elastic-stack-7-14-0-security-update/280344
- https://security.netapp.com/advisory/ntap-20211008-0002/
- https://www.elastic.co/community/security/
- https://discuss.elastic.co/t/elastic-stack-7-14-0-security-update/280344
- https://security.netapp.com/advisory/ntap-20211008-0002/
- https://www.elastic.co/community/security/
Get alerted when CVE-2021-22147 or the next vulnerability affects your stack