What’s Vulnerable › Vulnerabilities
CVE-2021-22148
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-15 · updated 2026-06-17
- Weakness: CWE-732
Description
Elastic Enterprise Search App Search versions before 7.14.0 was vulnerable to an issue where API keys were not bound to the same engines as their creator. This could lead to a less privileged user gaining access to unauthorized engines.
Affected products
- Elastic Enterprise Search: before 7.14.0 — fixed in 7.14.0
How to fix
Upgrade to a fixed version: Elastic Enterprise Search 7.14.0. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elastic-stack-7-14-0-security-update/280344
- https://www.elastic.co/community/security/
- https://discuss.elastic.co/t/elastic-stack-7-14-0-security-update/280344
- https://www.elastic.co/community/security/
Get alerted when CVE-2021-22148 or the next vulnerability affects your stack