What’s Vulnerable › Vulnerabilities
CVE-2021-22150: Kibana code execution issue
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-22 · updated 2026-06-17
- Weakness: CWE-94
Description
It was discovered that a user with Fleet admin permissions could upload a malicious package. Due to using an older version of the js-yaml library, this package would be loaded in an insecure manner, allowing an attacker to execute commands on the Kibana server.
Affected products
- Kibana: from 7.10.2 before 7.14.1 — fixed in 7.14.1
How to fix
Upgrade to a fixed version: Kibana 7.14.1. Check the vendor advisory for mitigations.
References
- https://discuss.elastic.co/t/elastic-stack-7-14-1-security-update/283077
- https://www.elastic.co/community/security
- https://discuss.elastic.co/t/elastic-stack-7-14-1-security-update/283077
- https://www.elastic.co/community/security
Get alerted when CVE-2021-22150 or the next vulnerability affects your stack