What’s Vulnerable › Vulnerabilities
CVE-2021-22158
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-06 · updated 2026-06-17
- Weakness: CWE-611
Description
The Proofpoint Insider Threat Management Server (formerly ObserveIT Server) is vulnerable to XML external entity (XXE) injection in the Web Console. The vulnerability requires admin user privileges and knowledge of the XML file's encryption key to successfully exploit. All versions before 7.11 are affected.
Affected products
- Proofpoint Insider Threat Management: from 7.9.0 before 7.9.3; from 7.10.0 before 7.10.3; from 7.11.0 before 7.11.1 — fixed in 7.10.3, 7.11.1, 7.9.3
How to fix
Upgrade to a fixed version: Proofpoint Insider Threat Management 7.10.3, 7.11.1, 7.9.3. Check the vendor advisory for mitigations.
References
- https://www.proofpoint.com/us/security/security-advisories/pfpt-sa-2021-0003
- https://www.proofpoint.com/us/security/security-advisories/pfpt-sa-2021-0003
Get alerted when CVE-2021-22158 or the next vulnerability affects your stack