What’s Vulnerable › Vulnerabilities
CVE-2021-22166
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-15 · updated 2026-06-17
- Weakness: CWE-400
Description
An attacker could cause a Prometheus denial of service in GitLab 13.7+ by sending an HTTP request with a malformed method
Affected products
- GitLab: from 13.7.0 before 13.7.2 — fixed in 13.7.2
How to fix
Upgrade to a fixed version: GitLab 13.7.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22166.json
- https://gitlab.com/gitlab-org/labkit/-/issues/29
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22166.json
- https://gitlab.com/gitlab-org/labkit/-/issues/29
Get alerted when CVE-2021-22166 or the next vulnerability affects your stack