What’s Vulnerable › Vulnerabilities
CVE-2021-22167
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-15 · updated 2026-06-17
Description
An issue has been discovered in GitLab affecting all versions starting from 12.1. Incorrect headers in specific project page allows attacker to have a temporary read access to the private repository
Affected products
- GitLab: from 12.1.0 before 13.5.6; from 13.6.0 before 13.6.4; from 13.7.0 before 13.7.2 — fixed in 13.5.6, 13.6.4, 13.7.2
How to fix
Upgrade to a fixed version: GitLab 13.5.6, 13.6.4, 13.7.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22167.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/289944
- https://hackerone.com/reports/1043480
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22167.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/289944
- https://hackerone.com/reports/1043480
Get alerted when CVE-2021-22167 or the next vulnerability affects your stack