What’s Vulnerable › Vulnerabilities
CVE-2021-22168
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-15 · updated 2026-06-17
- Weakness: CWE-400
Description
A regular expression denial of service issue has been discovered in NuGet API affecting all versions of GitLab starting from version 12.8.
Affected products
- GitLab: from 12.8.0 before 13.5.6; from 13.6.0 before 13.6.4; from 13.7.0 before 13.7.2 — fixed in 13.5.6, 13.6.4, 13.7.2
How to fix
Upgrade to a fixed version: GitLab 13.5.6, 13.6.4, 13.7.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22168.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/289950
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22168.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/289950
Get alerted when CVE-2021-22168 or the next vulnerability affects your stack