What’s Vulnerable › Vulnerabilities
CVE-2021-22181
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-11 · updated 2026-06-17
- Weakness: CWE-400
Description
A denial of service vulnerability in GitLab CE/EE affecting all versions since 11.8 allows an attacker to create a recursive pipeline relationship and exhaust resources.
Affected products
- GitLab: from 11.8.0 before 13.10.5; from 13.11.0 before 13.11.5; from 13.12.0 before 13.12.2 — fixed in 13.10.5, 13.11.5, 13.12.2
How to fix
Upgrade to a fixed version: GitLab 13.10.5, 13.11.5, 13.12.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22181.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/249100
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22181.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/249100
Get alerted when CVE-2021-22181 or the next vulnerability affects your stack