What’s Vulnerable › Vulnerabilities
CVE-2021-22182
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-03 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue has been discovered in GitLab affecting all versions starting with 13.7. GitLab was vulnerable to a stored XSS in merge request.
Affected products
- GitLab: from 13.7.0 before 13.7.6; from 13.8.0 before 13.8.2 — fixed in 13.7.6, 13.8.2
How to fix
Upgrade to a fixed version: GitLab 13.7.6, 13.8.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22182.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/280779
- https://hackerone.com/reports/1030189
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22182.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/280779
- https://hackerone.com/reports/1030189
Get alerted when CVE-2021-22182 or the next vulnerability affects your stack