What’s Vulnerable › Vulnerabilities
CVE-2021-22183
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-04 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue has been discovered in GitLab affecting all versions starting with 11.8. GitLab was vulnerable to a stored XSS in the epics page, which could be exploited with user interactions.
Affected products
- GitLab: from 11.8 before 13.6.6; from 13.7.0 before 13.7.6; from 13.8.0 before 13.8.2 — fixed in 13.6.6, 13.7.6, 13.8.2
How to fix
Upgrade to a fixed version: GitLab 13.6.6, 13.7.6, 13.8.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22183.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/294176
- https://hackerone.com/reports/1055814
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22183.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/294176
- https://hackerone.com/reports/1055814
Get alerted when CVE-2021-22183 or the next vulnerability affects your stack