What’s Vulnerable › Vulnerabilities
CVE-2021-22192
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-24 · updated 2026-06-17
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 13.2 allowing unauthorized authenticated users to execute arbitrary code on the server.
Affected products
- GitLab: from 13.2.0 before 13.7.9; from 13.8.0 before 13.8.6; from 13.9.0 before 13.9.4 — fixed in 13.7.9, 13.8.6, 13.9.4
How to fix
Upgrade to a fixed version: GitLab 13.7.9, 13.8.6, 13.9.4. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22192.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/324452
- https://hackerone.com/reports/1125425
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22192.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/324452
- https://hackerone.com/reports/1125425
Get alerted when CVE-2021-22192 or the next vulnerability affects your stack