What’s Vulnerable › Vulnerabilities
CVE-2021-22196
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-02 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 13.4. It was possible to exploit a stored cross-site-scripting in merge request via a specifically crafted branch name.
Affected products
- GitLab: from 13.4.0 before 13.8.7; from 13.9.0 before 13.9.5; from 13.10.0 before 13.10.1 — fixed in 13.10.1, 13.8.7, 13.9.5
How to fix
Upgrade to a fixed version: GitLab 13.10.1, 13.8.7, 13.9.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22196.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/254710
- https://hackerone.com/reports/977697
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22196.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/254710
- https://hackerone.com/reports/977697
Get alerted when CVE-2021-22196 or the next vulnerability affects your stack