What’s Vulnerable › Vulnerabilities
CVE-2021-22199
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-22 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue has been discovered in GitLab affecting all versions starting with 12.9. GitLab was vulnerable to a stored XSS if scoped labels were used.
Affected products
- GitLab: from 12.9 before 13.8.7; from 13.9.0 before 13.9.5; from 13.10.0 before 13.10.1 — fixed in 13.10.1, 13.8.7, 13.9.5
How to fix
Upgrade to a fixed version: GitLab 13.10.1, 13.8.7, 13.9.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22199.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/291004
- https://hackerone.com/reports/1050189
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22199.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/291004
- https://hackerone.com/reports/1050189
Get alerted when CVE-2021-22199 or the next vulnerability affects your stack