What’s Vulnerable › Vulnerabilities
CVE-2021-22210
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-06 · updated 2026-06-17
- Weakness: CWE-770
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 13.2. When querying the repository branches through API, GitLab was ignoring a query parameter and returning a considerable amount of results.
Affected products
- GitLab: from 13.2.0 before 13.9.7; from 13.10.0 before 13.10.4; from 13.11.0 before 13.11.2 — fixed in 13.10.4, 13.11.2, 13.9.7
How to fix
Upgrade to a fixed version: GitLab 13.10.4, 13.11.2, 13.9.7. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22210.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/322500
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22210.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/322500
Get alerted when CVE-2021-22210 or the next vulnerability affects your stack