What’s Vulnerable › Vulnerabilities
CVE-2021-22211
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-06 · updated 2026-06-17
- Weakness: CWE-863
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 13.7. GitLab Dependency Proxy, under certain circumstances, can impersonate a user resulting in possibly incorrect access handling.
Affected products
- GitLab: from 13.7.0 before 13.9.7; from 13.10.0 before 13.10.4; from 13.11.0 before 13.11.2 — fixed in 13.10.4, 13.11.2, 13.9.7
How to fix
Upgrade to a fixed version: GitLab 13.10.4, 13.11.2, 13.9.7. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22211.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/298847
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22211.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/298847
Get alerted when CVE-2021-22211 or the next vulnerability affects your stack