What’s Vulnerable › Vulnerabilities
CVE-2021-22214
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 27.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-08 · updated 2026-06-17
- Weakness: CWE-918
Description
When requests to the internal network for webhooks are enabled, a server-side request forgery vulnerability in GitLab CE/EE affecting all versions starting from 10.5 was possible to exploit for an unauthenticated attacker even on a GitLab instance where registration is limited
Affected products
- GitLab: from 10.5 before 13.10.5; from 13.11 before 13.11.5; from 13.12 before 13.12.2 — fixed in 13.10.5, 13.11.5, 13.12.2
How to fix
Upgrade to a fixed version: GitLab 13.10.5, 13.11.5, 13.12.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22214.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/322926
- https://hackerone.com/reports/1110131
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22214.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/322926
- https://hackerone.com/reports/1110131
Get alerted when CVE-2021-22214 or the next vulnerability affects your stack