What’s Vulnerable › Vulnerabilities
CVE-2021-22229
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-06 · updated 2026-06-17
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting with 12.8. Under a special condition it was possible to access data of an internal repository through project fork done by a project member.
Affected products
- GitLab: from 12.8 before 13.11.6; from 13.12.0 before 13.12.6; from 14.0.0 before 14.0.2 — fixed in 13.11.6, 13.12.6, 14.0.2
How to fix
Upgrade to a fixed version: GitLab 13.11.6, 13.12.6, 14.0.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22229.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/332609
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22229.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/332609
Get alerted when CVE-2021-22229 or the next vulnerability affects your stack