What’s Vulnerable › Vulnerabilities
CVE-2021-22235
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-20 · updated 2026-06-17
- Weakness: CWE-835
Description
Crash in DNP dissector in Wireshark 3.4.0 to 3.4.6 and 3.2.0 to 3.2.14 allows denial of service via packet injection or crafted capture file
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- Wireshark Foundation Wireshark: from 3.2.0 before 3.2.15; from 3.4.0 before 3.4.7 — fixed in 3.2.15, 3.4.7
How to fix
Upgrade to a fixed version: Wireshark Foundation Wireshark 3.2.15, 3.4.7. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22235.json
- https://gitlab.com/wireshark/wireshark/-/issues/17462
- https://lists.debian.org/debian-lts-announce/2021/12/msg00015.html
- https://security.gentoo.org/glsa/202210-04
- https://www.debian.org/security/2021/dsa-5019
- https://www.wireshark.org/security/wnpa-sec-2021-05.html
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22235.json
- https://gitlab.com/wireshark/wireshark/-/issues/17462
- https://lists.debian.org/debian-lts-announce/2021/12/msg00015.html
- https://security.gentoo.org/glsa/202210-04
- https://www.debian.org/security/2021/dsa-5019
- https://www.wireshark.org/security/wnpa-sec-2021-05.html
Get alerted when CVE-2021-22235 or the next vulnerability affects your stack