What’s Vulnerable › Vulnerabilities
CVE-2021-22236
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-25 · updated 2026-06-17
- Weakness: CWE-863
Description
Due to improper handling of OAuth client IDs, new subscriptions generated OAuth tokens on an incorrect OAuth client application. This vulnerability is present in GitLab CE/EE since version 14.1.
Affected products
- GitLab: from 14.1.0 before 14.1.2 — fixed in 14.1.2
How to fix
Upgrade to a fixed version: GitLab 14.1.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22236.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/334925
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22236.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/334925
Get alerted when CVE-2021-22236 or the next vulnerability affects your stack