What’s Vulnerable › Vulnerabilities
CVE-2021-22240
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-05 · updated 2026-06-17
- Weakness: CWE-863
Description
Improper access control in GitLab EE versions 13.11.6, 13.12.6, and 14.0.2 allows users to be created via single sign on despite user cap being enabled
Affected products
- GitLab: from 13.7.0 before 13.11.6; from 13.12.0 before 13.12.6; from 14.0.0 before 14.0.2 — fixed in 13.11.6, 13.12.6, 14.0.2
How to fix
Upgrade to a fixed version: GitLab 13.11.6, 13.12.6, 14.0.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22240.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/327641
- https://hackerone.com/reports/1166566
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22240.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/327641
- https://hackerone.com/reports/1166566
Get alerted when CVE-2021-22240 or the next vulnerability affects your stack