What’s Vulnerable › Vulnerabilities
CVE-2021-22260
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-05 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored Cross-Site Scripting vulnerability in the DataDog integration in all versions of GitLab CE/EE starting from 13.7 before 14.0.9, all versions starting from 14.1 before 14.1.4, and all versions starting from 14.2 before 14.2.2 allows an attacker to execute arbitrary JavaScript code on the victim's behalf
Affected products
- GitLab: from 13.7.0 before 14.0.9; from 14.1.0 before 14.1.4; from 14.2.0 before 14.2.2 — fixed in 14.0.9, 14.1.4, 14.2.2
How to fix
Upgrade to a fixed version: GitLab 14.0.9, 14.1.4, 14.2.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22260.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/336614
- https://hackerone.com/reports/1257383
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22260.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/336614
- https://hackerone.com/reports/1257383
Get alerted when CVE-2021-22260 or the next vulnerability affects your stack