What’s Vulnerable › Vulnerabilities
CVE-2021-22263
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-11 · updated 2026-06-17
- Weakness: CWE-269
Description
An issue has been discovered in GitLab affecting all versions starting from 13.0 before 14.0.9, all versions starting from 14.1 before 14.1.4, all versions starting from 14.2 before 14.2.2. A user account with 'external' status which is granted 'Maintainer' role on any project on the GitLab instance where 'project tokens' are allowed may elevate its privilege to 'Internal' and access Internal projects.
Affected products
- GitLab: from 13.0.0 before 14.0.9; from 14.1.0 before 14.1.4; from 14.2.0 before 14.2.2 — fixed in 14.0.9, 14.1.4, 14.2.2
How to fix
Upgrade to a fixed version: GitLab 14.0.9, 14.1.4, 14.2.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22263.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/331473
- https://hackerone.com/reports/1193062
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-22263.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/331473
- https://hackerone.com/reports/1193062
Get alerted when CVE-2021-22263 or the next vulnerability affects your stack