What’s Vulnerable › Vulnerabilities
CVE-2021-22275: Denial of service vulnerability on Automation Runtime webserver
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-13 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer Overflow vulnerability in B&R Automation Runtime webserver allows an unauthenticated network-based attacker to stop the cyclic program on the device and cause a denial of service.
Affected products
- B&R Industrial Automation Automation Runtime: before 4.91 — fixed in 4.91
How to fix
Upgrade to a fixed version: B&R Industrial Automation Automation Runtime 4.91. Check the vendor advisory for mitigations.
References
- https://www.br-automation.com/downloads_br_productcatalogue/assets/1625405588264-en-original-1.0.pdf
- https://www.br-automation.com/downloads_br_productcatalogue/assets/1625405588264-en-original-1.0.pdf
Get alerted when CVE-2021-22275 or the next vulnerability affects your stack